Table des matières

Sujet précédent

Bienvenue sur ce tutoriel Python pour lycéens !

Sujet suivant

Première utilisation

Installation

De quoi a-t-on besoin ?
  • D’une version de Python. Il en existe plusieurs. Attention, les anciennes versions en 2.x sont incompatibles avec les plus récentes en 3.x.
  • Et au minimum, d’un éditeur de texte.

Mais pour débuter, le plus simple est d’utiliser un environnement de développement intégré :

Sous linux

Cela peut être :
  • IDLE (fourni avec certaines distributions de Python),
  • Gedit avec un greffon Python,
  • DrPython (disponible aussi sous windows).

Sous windows

Cela peut aussi être IDLE ou bien Pyscripter. Mais inutile de télécharger ce dernier séparément puisqu’il est inclus dans le pack Portable Python. L’installatation de ce pack est très simple et comprend une version récente de Python ou des versions plus anciennes (2.x). Pour télécharger Portable Python, allez sur cette page de téléchargement puis une fois la version choisie, suivez un des liens HTTP ou FTP.

Note

L’académie d’Amiens propose AmiensPython qui est un produit dérivé de Portable Python et qui contient entre autres une version francisée de Pyscripter.

Une fois cette installation faite, il suffit d’ouvrir Pyscripter et alors Python est prêt à l’emploi.

_images/portablepython-logo.jpg _images/pyscripter-logo.jpg